Investitori

Base di conoscenze

1 000 FAQ, 500 tutorial e video esplicativi. Qui ci sono delle soluzioni!

Questa guida illustra l'utilizzo di DELIMITER per creare funzioni MySQL su Server Cloud Infomaniak.

 

Introduzione

  • Quando si creano funzioni o procedure memorizzate in MySQL, è fondamentale comprendere il ruolo dei delimitatori.
  • L'uso corretto dei delimitatori è essenziale per evitare errori di sintassi che possono verificarsi a causa della presenza di più istruzioni SQL all'interno di una singola definizione di funzione o procedura.

 

Comprendere il delimitatore

Un delimitatore è un carattere o una sequenza di caratteri utilizzati per separare le istruzioni SQL in uno script. Per impostazione predefinita, MySQL utilizza il punto e virgola (;) come delimitatore. Tuttavia, quando si creano funzioni, procedure memorizzate o trigger che contengono più istruzioni SQL, è necessario modificare temporaneamente il delimitatore per evitare errori di sintassi.

Quando si crea una funzione, una procedura o un trigger, spesso è necessario utilizzare più istruzioni SQL all'interno del blocco BEGIN...END. Poiché il punto e virgola (;) viene utilizzato anche per terminare queste istruzioni interne, MySQL potrebbe interpretare il primo punto e virgola come la fine della definizione della funzione, causando un errore di sintassi. Per risolvere questo problema, è necessario modificare il delimitatore durante la definizione della funzione.

 

Creare una funzione semplice utilizzando delimitatori personalizzati

Prima di definire la funzione, è necessario indicare a MySQL che si utilizzerà un delimitatore diverso. Nell'esempio seguente, $$ viene utilizzato come nuovo delimitatore:

DELIMITER $$

Con il nuovo delimitatore in uso, ora puoi definire la tua funzione. L'istruzione CREATE FUNCTION include il corpo della funzione, dove puoi utilizzare istruzioni SQL interne separate da punti e virgola senza che ciò crei problemi:

CREATE FUNCTION hello_world()
RETURNS TEXT
LANGUAGE SQL
BEGIN
RETURN 'Hello World';
END;
$$

In questo esempio:

  • CREATE FUNCTION hello_world(): dichiara l'inizio della definizione della funzione hello_world.
  • RETURNS TEXT: specifica il tipo di dati che la funzione restituisce.
  • LANGUAGE SQL: indica che il linguaggio utilizzato per la funzione è SQL.
  • BEGIN ... END: racchiude il codice della funzione. All'interno, il punto e virgola viene utilizzato per separare le istruzioni SQL.
  • RETURN 'Hello World';: istruzione SQL che restituisce la stringa di caratteri Hello World.

Dopo aver definito la funzione, riportare il delimitatore al suo stato predefinito (il punto e virgola). Questo consente di continuare a eseguire le istruzioni SQL abituali nei successivi script:

DELIMITER ;

Questa FAQ è stata utile?

Questa guida spiega come visualizzare l'attività dei file sul server del tuo hosting Infomaniak.

 

Log di attività dello spazio FTP

Per conoscere l'attività degli scambi sul tuo spazio FTP, contatta l'assistenza Infomaniak e richiedi i log FTP, autenticandoti preventivamente con le credenziali relative alla gestione del tuo hosting web.

Il log viene aggiornato solo in caso di attività FTP.

Guida alla lettura dei log: http://www.castaglia.org/proftpd/doc/xferlog.html


Questa FAQ è stata utile?

Il modulo CGID per Apacheè stato disattivato sulle offerte di hosting web condivisodi Infomaniak.

Se necessario, è opportuno valutare il passaggio a un piano superiore, optando per un Server Cloud, qualora si utilizzi attualmente un servizio di hosting web condiviso. Questa operazione può essere eseguita in modo trasparente: per maggiori informazioni, consultare questa guida.


Questa FAQ è stata utile?

Questa guida spiega come aumentare il valore di max_children su Server Cloud per aumentare il numero di processi PHP simultanei che possono essere utilizzati dal tuo sito. Questo sarà molto utile per risolvere i problemi di caricamento infinito delle pagine del tuo sito.

 

Introduzione

  • Per impostazione predefinita, su tutti gli hosting, il limite di max_children è impostato a 20.
    • Sebbene sia possibile aumentare questo valore tramite il Manager Infomaniak, il limite di max_children viene automaticamente regolato in base alla configurazione del Server Cloud.
    • Per aumentare questo limite su un hosting condiviso, passa a un Server Cloud.
  • Per capire come calcolare con precisione il numero di max_children necessari, consulta questo articolo.

 

Aumentare il valore max_children

Prerequisiti

  • Assicurarsi di disporre delle risorse necessarie sul server Cloud.
  • Verificare che tutte le risorse del server Cloud non siano già in uso; in caso contrario, l'aumento del valore di max_children non avrà alcun effetto (Modificare le risorse del server Cloud).
  • Controllare il monitoraggio delle risorse del server, nel caso in cui le risorse del server raggiungano il limite, sarà necessarioverificare l'ottimizzazione dei processi e del sito prima di valutare l'aumento del valore di max_children.
  • Consultare i report degli errori PHP dalla cartella /ik-logs (log del processo principale PHP - nome del file: php-fpm.log) per verificare se il limite "max_children" è stato superato... esempio di errore: [05-Jul-2024 09:08:58] WARNING: [pool www.infomaniak.ch] server reached max_children setting (20), consider raising it

Per accedere alla gestione dei parametri PHP / Apache del sito per il quale è necessario aumentare il valore max_children su Server Cloud, consultare questa guida.

Potrai, in particolare…

  • … scegliere un nuovo valore per max_children:

Non dimenticare di salvare le modifiche nella parte inferiore della pagina.

 

Limiti in base al server

Limite di max_children in base alle risorse del Server Cloud:

Configurazione Server Cloudmax_children
2 CPU / 6 GB di RAM20
4 CPU / 12 GB RAM40
6 CPU / 18 GB RAM60
8 CPU / 24 GB RAM80
12 CPU / 36 GB RAM120
16 CPU / 48 GB RAM160
24 CPU / 72 GB RAM240
32 CPU / 96 o 128 GB di RAM320

Questa FAQ è stata utile?

Questa guida è rivolta a chi desidera eseguire test di vulnerabilità sul proprio sito/server ospitato da Infomaniak.

 

Elementi consentiti e limitati

Potete eseguire test di vulnerabilità (SQL injection, XSS, ecc.), test di intrusione o test di penetrazione (pentest) sul vostro hosting Infomaniak solo alle seguenti condizioni:

  • dalle 9:00 alle 17:00 CET
  • dal lunedì al venerdì
  • con il pacchetto base minimo, indipendentemente dal software utilizzato (ad esempio AppScan)
  • senza mai effettuare alcun tipo di attacco DoS o DDoS (Denial of Service)
  • nel rispetto delle Condizioni Generali d'Uso di Infomaniak, in particolare delle regole relative all'utilizzo condiviso dei servizi

 

Qualsiasi uso improprio potrà comportare la risoluzione anticipata del contratto da parte di Infomaniak.


Questa FAQ è stata utile?

Questa guida illustra l'utilizzo di script Perl o Python sugli hosting di Infomaniak e la gestione dei relativi moduli.

 

Prerequisiti

  • Hosting web condiviso: il modulo CGI non è più disponibile; pertanto, l'esecuzione di script Perl e Python non è supportata.
  • Server Cloud gestiti: per usufruire delle ultime tecnologie, è possibile aggiornare il proprio Server Cloud.

 

Configurazione Web (Apache/CGI)

Per eseguire script Python o Perl tramite Apache su Server Cloud, l'interpretazione dei file con le estensioni .py e .pl non è attiva per impostazione predefinita.

Utilizzando il software/client FTP o il Web FTP, aggiungere e adattare la seguente direttiva nel file .htaccess situato nella cartella contenente gli script:

AddHandler cgi-script .pl .cgi .py
Options +ExecCGI

 

Installazione di moduli aggiuntivi

Su un Server Cloud, è possibile installare librerie di terze parti non presenti di default.

Python

  • L'installazione avviene tramite PIP, un gestore di pacchetti utilizzato per installare e gestire pacchetti scritti in Python.
  • Infomaniak offre PIP e PIP3 tramite lo strumento Fast Installer.
  • Una volta installato PIP, è possibile installare i moduli Python specificando --user nel comando. Ad esempio:
  • pip3 install mysql-connector-python --user

Perl

  • L'aggiunta di moduli Perl avviene anch'essa tramite SSH (console). È necessario installarli nella directory dell'utente e definirne il percorso completo all'interno degli script.

 

Informazioni tecniche importanti

  • Percorso dell'interprete: /usr/bin/python
  • Estensioni: gli script devono avere l'estensione .pl, .cgi o .py.
  • Limitazioni: il modulo mod_python non è supportato.

 

Risoluzione degli errori (CGIWrap)

Se riscontri il seguente errore durante il caricamento di un'immagine:

CGIWrap Error: Execution of this script not permitted
Request Data:Extra Path Info: /dossier/.../image.PL.12.34.gif

Il server interpreta il file come uno script perché nel suo nome è presente ".PL" (o .PY).
Soluzione: è sufficiente rinominare il file per rimuovere questa indicazione (ad esempio: image-12-34.gif).


Questa FAQ è stata utile?

Questa guida ti sarà utile, ad esempio, se desideri installare un pacchetto come pymysql e questo richiede una versione di Python superiore a quella offerta di default sul tuo hosting.

 

Introduzione

  • Anaconda è una distribuzione gratuita e open source dei linguaggi di programmazione Python e R; il suo obiettivo è semplificare la gestione dei pacchetti e la distribuzione.
  • Si consiglia di utilizzare Miniconda (versione leggera di conda); si installa nella directory dell'utente, evitando conflitti con il Python di sistema e non richiedendo privilegi di amministratore.
  • Consultare la documentazione ufficiale.

 

1. Scaricare il programma di installazione

Ad esempio, la versione Linux a 64 bit per Python 3.11.

2. Verificare l'integrità (Hash SHA256)

 

2. Contrôler l'intégrité (Hash SHA256)

user@server:~$ sha256sum Miniconda3-py311_23.10.0-1-Linux-x86_64.sh
6c714a33ea348303f909194246990422e698889417d74b9714856b3e9a7e6c3a  Miniconda3-py311_23.10.0-1-Linux-x86_64.sh

 

3. Avviare l'installazione

L'argomento -b consente un'installazione silenziosa. Per impostazione predefinita, Miniconda verrà installato in ~/miniconda3.

user@server:~$ bash Miniconda3-py311_23.10.0-1-Linux-x86_64.sh -b
PREFIX=/home/clients/your_client_hash/miniconda3
Estrazione dei file...
Raccolta dei metadati dei pacchetti (current_repodata.json): completato
Risoluzione dell'ambiente: completato
Esecuzione della transazione: completato
Installazione completata.

 

4. Inizializzare e attivare Conda

Per utilizzare Conda immediatamente e a ogni connessione SSH:

user@server:~$ ~/miniconda3/bin/conda init bash
no change     /home/clients/your_client_hash/miniconda3/condabin/conda
...
modified      /home/clients/your_client_hash/.bashrc

user@server:~$ source ~/.bashrc

 

5. Installare un pacchetto (esempio: pymysql)

Una volta attivato, il prefisso (base) apparirà prima del prompt dei comandi. A questo punto, potrai installare i tuoi strumenti senza utilizzare sudo o --user.

(base) user@server:~$ python -V
Python 3.11.5

(base) user@server:~$ pip install pymysql
Collecting pymysql
  Downloading PyMySQL-1.1.0-py3-none-any.whl (44 kB)
Installing collected packages: pymysql
Successfully installed pymysql-1.1.0

Questa FAQ è stata utile?

Questa guida riguarda il supporto delle funzioni di hash sicure (in particolare SHA-256) sui server Infomaniak, nonché l'importanza della sicurezza dei certificati SSL/TLS tramite l'utilizzo di CSR generati con SHA-256.

 

Algoritmo di hash SHA-256

La funzione di hash crittografico SHA-1 è supportata e i server Infomaniak supportano anche la funzione SHA-256, utile in particolare per Paypal e SaferPay (SIX).

Le richieste di firma del certificato (CSR) sono in formato SHA-256 e non SHA-1.


Questa FAQ è stata utile?

Questa guida spiega come eseguire un backup di un VPS Cloud sotto forma di snapshot.

 

Introduzione

  • Uno snapshot è come una fotografia del tuo VPS Cloud in un determinato momento, che conterrà tutto ciò che si trova sul tuo server, incluso il sistema operativo, le applicazioni, i dati, ecc.
  • Gli snapshot possono essere utilizzati in particolare per…
    • … proteggere il tuo VPS Cloud in caso di problemi: se riscontri un problema con il tuo VPS Cloud, puoi ripristinare uno snapshot per tornare a uno stato precedente.
    • … testare modifiche senza rischi: prima di apportare modifiche importanti al tuo VPS Cloud, puoi creare uno snapshot per poter tornare indietro, se necessario.
  • Avrete a disposizione un backup gratuito per salvare l'intero server in uno spazio dedicato; in caso di necessità, è possibile ordinare spazi aggiuntivi o eliminare un backup per crearne uno nuovo.
  • Sono possibili due tipi di backup:
    1. Backup dei dati: consente di creare un'immagine del volume che contiene i dati (non disponibile per le distribuzioni Windows).
    2. Backup del sistema operativo: consente di creare un'immagine del volume che contiene il sistema operativo. Questo tipo di backup comporta un'interruzione di alcuni minuti delle applicazioni e dei siti web.
  • Si consiglia di creare snapshot regolarmente, ad esempio una volta alla settimana o al mese; in questo modo sarà possibile disporre di una cronologia del VPS Cloud e ripristinare una versione precedente in caso di problemi.
  • È ovviamente possibile ripristinare lo stato del VPS Cloud utilizzando lo snapshot creato in precedenza.

 

Creare uno snapshot

Per farlo:

  1. Clicca qui per accedere alla gestione del tuo prodotto tramite il pannello di controllo Infomaniak (hai bisogno di aiuto?).
  2. Clicca direttamente sul nome assegnato al prodotto in questione.
  3. Fare clic su Snapshot nel menu laterale sinistro.
  4. Fare clic sul pulsante blu Crea uno snapshot:
  5. Scegli il tipo di snapshot da creare (dati o sistema operativo).
  6. Fai clic sul pulsante blu per avviare la creazione dello snapshot:
  7. Viene inviata un'e-mail quando viene creato lo snapshot.

 

Eliminare uno snapshot

Per farlo:

  1. Clicca qui per accedere alla gestione del tuo prodotto tramite il pannello di controllo Infomaniak (hai bisogno di aiuto?).
  2. Fate clic direttamente sul nome assegnato al prodotto in questione.
  3. Fate clic su Snapshot nel menu laterale sinistro.
  4. Fare clic sul menu azioni ⋮ a destra dell'elemento interessato nella tabella visualizzata.
  5. Fare clic su Elimina:

 

Ordinare snapshot aggiuntivi

Per farlo:

  1. Clicca qui per accedere alla gestione del tuo prodotto tramite il pannello di controllo Infomaniak (hai bisogno di aiuto?).
  2. Clicca direttamente sul nome assegnato al prodotto in questione.
  3. Fare clic su Snapshot nel menu laterale sinistro.
  4. Fare clic sull'icona del carrello della spesa:
  5. Seguire le istruzioni per completare l'ordine.

Non è possibile ordinare un'istantanea aggiuntiva se è già in corso la creazione di un'istantanea.


Questa FAQ è stata utile?

Questa guida spiega come visualizzare l'indirizzo IP di un sito sul tuo Hosting Web.

 

Introduzione

  • L'indirizzo IPv4 è in linea di principio lo stesso per tutti i siti ospitati (a meno che non abbiate acquistato un indirizzo IP dedicato).

 

Visualizzare l'indirizzo IP del vostro sito

L'indirizzo IP è indicato nella pagina di gestione dell'hosting (Starter o che contiene più siti):

  1. Clicca qui per accedere alla gestione degli hosting e dei siti nel tuo Manager Infomaniak (❓: guida).
  2. Fare clic sul nome del sito web in questione.
  3. Fare quindi clic sulla freccia verso il basso ‍ per espandere la sezione Informazioni di questo hosting.
  4. L'indirizzo IPv4 è visualizzato nella pagina:
  5. L'indirizzo IPv6 è visualizzato anche nel caso degli hosting a pagamento:

Questa FAQ è stata utile?

Questa guida illustra in dettaglio gli errori di tipo "502 Bad Gateway" che possono verificarsi durante la visita di un sito web.

 

Introduzione

  • L'errore 502 Bad Gateway si verifica quando il server che funge da gateway tra il browser e il server web di origine riceve una risposta non valida.
  • Questo errore può essere causato da un server web sovraccarico, da problemi di comunicazione tra una CDN e il server web di hosting o da un server proxy configurato in modo errato.
  • A volte, l'errore può essere causato da un'impostazione errata nel server DNS.

 

Possibili soluzioni

Per risolvere l'errore 502 Bad Gateway, spesso è necessario procedere per esclusione:

  • Verificare se si tratta di un sovraccarico momentaneo del server: è sufficiente ricaricare la pagina dopo qualche minuto affinché l'errore scompaia.
  • Svuota la cache del browser.
  • Prova con un altro browser.

Questa FAQ è stata utile?

Questa guida illustra le specifiche relative alla gestione di MongoDB sul tuo Server Cloud gestito, in particolare per quanto riguarda il ciclo di vita delle versioni.

 

Introduzione

  • Ogni nuova installazione dell'applicazione distribuisce per impostazione predefinita MongoDB versione 7.0 (o superiore).

 

Passaggio dalla versione 6 alla 7

Non è possibile eseguire un aggiornamento automatico dalla versione 6 alla versione 7 direttamente dalla vostra interfaccia.

Sono disponibili due soluzioni:

  1. Ordinare un nuovo Server Cloud: questo sarà dotato nativamente della versione 7, in seguito potrete migrare i vostri dati.
  2. Reinstallare l'applicazione: disinstallare e quindi reinstallare MongoDB sul server attuale.

La disinstallazione dell'applicazione elimina tutti i dati MongoDB. Inoltre, non sarà più possibile reinstallare la versione 6 dopo questa operazione.

Backup e responsabilità

In qualità di amministratore, la gestione e l'integrità dei tuoi dati sono interamente di tua responsabilità.

Prima di effettuare qualsiasi operazione (in particolare la reinstallazione):

  • Esegui i tuoi backup ed esporta (dump) i tuoi database.
  • Prevedi l'importazione manuale dei tuoi dati una volta che la nuova versione sarà attiva.

Questa FAQ è stata utile?

Questa guida spiega cosa è necessario verificare come visitatore di un sito web in caso di errore di tipo 403, al fine di risolvere il problema.

 

Cos'è l'errore 403?

Il codice di errore HTTP 403 indica generalmente che l'accesso a una risorsa è negato al client da parte del server.

 

In quali casi si verifica questo errore?

L'utente non è autenticato: il server richiede che l'utente si identifichi per accedere alla risorsa. Questo può verificarsi, ad esempio, per pagine private che richiedono l'autenticazione.

L'utente è autenticato ma non dispone delle autorizzazioni necessarie: il server riconosce l'utente, ma non gli consente l'accesso alla risorsa richiesta a causa di restrizioni di autorizzazioni o ruoli. Questa causa di errore 403 può essere dovuta a un problema di autorizzazioni errate su una cartella o un file. Per una cartella, il messaggio di errore è di tipo "403 Forbidden", per un file, "failed to open stream: Permission denied". In questo caso, è necessario verificare che le autorizzazioni delle cartelle/file siano corrette, ovvero almeno 644 per un file e 755 per una cartella. Consultare questa altra guida.

L'indirizzo IP dell'utente è bloccato o limitato: il server può bloccare l'accesso a un indirizzo IP specifico per motivi di sicurezza o per proteggere da attacchi. Consultare questa altra guida.

La risorsa richiesta non esiste sul server: in questo caso, il server restituisce un errore 403 anziché un errore 404 per evitare la divulgazione di informazioni riservate. Se si tenta di accedere alla propria pagina iniziale o a una parte del sito, indicando un indirizzo del tipo www.dominio.xyz o www.dominio.xyz/cartella/, assicurarsi che esista una pagina iniziale denominata "index.html o .htm o .php" posizionata nel punto corretto (alla radice dello spazio FTP, nella directory /web o nella directory /cartella/). Consultare questa guida.

Inoltre, verificare che non ci siano lettere maiuscole nel nome del file; tutti i nomi di file o cartelle devono essere in minuscolo, senza accenti né spazi.

Errore relativo allo script: se si stava eseguendo uno script, compilando un modulo o caricando un file online e si riceve questo tipo di messaggio:

Accès interdit!
Vous n'avez pas le droit d'accéder à l'objet demandé.
Soit celui-ci est protégé, soit il ne peut être lu par le serveur.
Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le gestionnaire du site.
Error 403

la causa potrebbe essere un filtro che impedisce l'uso non autorizzato degli script da parte di spammer. Infatti, l'antivirus Infomaniak blocca il caricamento di file tramite script o tramite FTP. Ciò significa concretamente che quando un hacker invia un file identificato come virus tramite un modulo, uno script non sicuro o tramite FTP, l'installazione viene bloccata direttamente, il file non viene caricato sul server e il caricamento genera un errore 403.

 

In caso di falsi positivi, contattare il supporto Infomaniak fornendo l'URL della pagina in cui si verifica questo messaggio di errore, in modo da diagnosticare con precisione l'origine del problema.

Esistono tuttavia molti altri casi in cui si potrebbe ricevere un messaggio "403 forbidden" e per ragioni molto diverse (script PHP, perl, mod_security, .htaccess, ...).


Questa FAQ è stata utile?

Questa guida consente di risolvere i problemi relativi ai caratteri speciali (accenti, emoji, ecc.) che non vengono visualizzati correttamente o che compaiono sotto forma di simboli come ??, spesso a causa di una codifica errata durante la connessione a MySQL.

 

Introduzione

  • Per impostazione predefinita, MySQL utilizza UTF-8.
  • I server MySQL più recenti sono generalmente configurati per utilizzare UTF-8 o UTF-8MB4 per impostazione predefinita.
    • Questo è adatto alla maggior parte dei casi, in particolare per le lingue internazionali e le emoji.
  • Consulta anche questa guida per scoprire come evitare problemi di codifica con caratteri non europei ed emoji nei tuoi progetti di sviluppo.

 

Definire il charset predefinito di MySQL / MariaDB (Server Cloud)

Con un Server Cloud Infomaniak, è possibile definire il charset predefinito (utf8 o utf8mb4):

  1. Clicca qui per accedere alla gestione del tuo prodotto sul Manager Infomaniak (hai bisogno di aiuto?).
  2. Fate clic direttamente sul nome assegnato al prodotto in questione.
  3. Fate clic su MariaDB nel menu laterale sinistro.
  4. Scegli il set di caratteri predefinito:
  5. Salva le modifiche in fondo alla pagina.

 

Forzare una codifica specifica (ad esempio latin1)

Se è necessario lavorare con un database in latin1 (ISO-8859-1), è necessario specificare esplicitamente la codifica durante la connessione, in base all'ambiente in uso.

Per le offerte attuali, inserisci il seguente codice in un file user.ini situato nella directory principale del tuo spazio web:

mysql.connect_charset = "latin1"
mysqli.connect_charset = "latin1"
pdo_mysql.connect_charset = "latin1"

o in PHP (API MySQL):

mysql_query("SET CHARACTER SET latin1");

 

Nei vecchi piani di hosting, forzare la connessione MySQL in latin1 tramite il file .htaccess situato nella directory principale del tuo hosting:

php_value mysql.connect_charset latin1
php_value mysqli.connect_charset latin1
php_value pdo_mysql.connect_charset latin1

Questa FAQ è stata utile?

Questa guida spiega come accedere ai backup automatici ed eseguire il ripristino di un file specifico di un sito web su un hosting Infomaniak.

 

Ripristinare file o cartelle specifici

A tal fine:

  1. Accedere al server FTP tramite Web FTP (hai bisogno di aiuto?).
  2. Accedi alla cartella /backups.
  3. Seleziona i file e/o le cartelle da ripristinare.
  4. Fare clic sul pulsante Copia:
  5. Selezionare la posizione in cui copiare/ripristinare i dati (i dati esistenti verranno sostituiti con i dati selezionati).

Questa FAQ è stata utile?

Questa guida riguarda MySQL/MariaDB e, in particolare, l'analisi degli indici e delle query con l' Hosting Web.

 

Slowlog per le query lente

Il log lento di MySQL è attivo su tutti i server MySQL e raccoglie le query che impiegano più di 5 secondi per essere eseguite. Se le vostre query sono ben strutturate, non dovreste mai visualizzare questi file. In caso contrario, consultateli regolarmente per correggere eventuali errori e garantire il corretto funzionamento del vostro sito.

Contattate l'assistenza Infomaniak per richiederli (ad eccezione dei vecchi hosting v1 - vecchia formula), in quanto sono consultabili direttamente tramite Web FTP, un livello sopra la directory /web, nella directory /logs.

 

E i log?

Non viene creato alcun log MySQL (ad eccezione dei slow log), poiché i server MySQL non sarebbero in grado di gestire il carico di milioni di log da registrare contemporaneamente. Se necessario, Infomaniak può attivare questo log MySQL per 5 minuti, in modo da consentirti di analizzarlo con EXPLAIN e determinare, ad esempio, quali indici sono utili. A tal fine, contatta l'assistenza Infomaniak in forma scritta.

 


* del tempo trascorso. Per quanto riguarda i blocchi, la documentazione fornisce la seguente precisazione: "Il tempo necessario per acquisire i blocchi iniziali non viene conteggiato come tempo di esecuzione".


Questa FAQ è stata utile?

Questa guida illustra in dettaglio l'offerta Server Cloud di Infomaniak e l'offerta VPS di Infomaniak, pensate per utilizzi diversi.

 

Introduzione

  • Infomaniak offre due soluzioni di hosting avanzato:
    1. il Server Cloud gestito, che consente di creare diversi hosting (spazi FTP/SSH) sui quali è possibile aggiungere i propri siti (vhost Apache),
    2. e il VPS (Server Virtuale Privato), che offre una libertà totale di amministrazione e risponde a esigenze diverse.

 

Server Cloud gestito

Il Server Cloud consente di superare i limiti di un hosting condiviso. È possibile creare e distribuire i propri siti web come si desidera, definire la directory principale di ciascun sito e regolare parametri quali memory_limit e max_execution_time.

Sono forniti strumenti integrati: cron job, Site Creator, installazione semplificata di WordPress, registri di accesso e di errore (log). È inoltre possibile aggiungere moduli Apache specifici o installare un sistema di cache.

L'ambiente software è gestito da Infomaniak (FastCGI, PHP-FPM). Non si dispone di una libertà totale per configurare il server (non è possibile installare software arbitrario), ma alcuni programmi specifici possono essere installati.

 

VPS (non gestito)

Il VPS offre il controllo completo sul server, ma la sua gestione è a tuo carico. Infomaniak si occupa dell'hardware e installa la versione di Linux o di Windows scelta al momento dell'ordine. Infomaniak non effettua interventi software: sei tu a gestire il sistema, installare e configurare i software.

Puoi riavviare il server tramite il Manager Infomaniak. È disponibile un sistema di snapshot (ad eccezione dell'offerta VPS Lite).

 

Contenuti video e alternative

Se il tuo progetto prevede principalmente un elevato volume di video, è spesso preferibile separare la distribuzione dei video dall'hosting principale. Insieme a un hosting condiviso, lo spazio VOD/AOD di Infomaniak consente di archiviare e distribuire video in modo efficiente, gestire i picchi di traffico e ottenere statistiche dettagliate sulle visualizzazioni.

 

Migrazione tra Server Cloud e VPS

Non esiste una soluzione di migrazione automatica tra un Server Cloud gestito e un VPS.Per passare da un'offerta all'altra, è necessario disattivare il prodotto che non si utilizza più e ordinare la nuova offerta. Infomaniak rimborsa, su richiesta, qualsiasi nuovo server se la disattivazione avviene entro 30 giorni dall'ordine.


Questa FAQ è stata utile?

Questa guida spiega come visualizzare e modificare le impostazioni di configurazione di MySQL / MariaDB di un Server Cloud. Queste impostazioni consentono di regolare il comportamento, le prestazioni e alcune funzionalità del servizio, comprese le limitazioni delle risorse.

 

Introduzione

  • MySQL è installato su un Server Cloud dedicato: le risorse non sono condivise con altri clienti.
  • È presente una sola istanza di MySQL o MariaDB per Server Cloud.
  • Il numero e le dimensioni dei database dipendono esclusivamente dallo spazio su disco e dalle risorse disponibili.
  • Per volumi di dati non relazionali molto elevati, si consiglia MongoDB.

 

Parametri configurabili di MySQL / MariaDB

Di seguito è riportato un elenco delle principali variabili che è possibile personalizzare nella propria istanza MySQL / MariaDB:

NomeDescrizioneValore
bulk_insert_buffer_sizeDimensione del buffer per le operazioni di inserimento in blocco8M
default_charsetDefinisce il set di caratteri predefinito per il databaseutf8mb4
declare_explicit_defaults_for_timestampConsente di definire esplicitamente i valori predefiniti per le colonne di tipo timestamp.""
declare_innodb_autoextend_incrementIncremento utilizzato per l'estensione automatica dello spazio tabella InnoDB""
declare_key_bufferDimensione del buffer delle chiavi per le tabelle MyISAM""
event_schedulerAbilita o disabilita lo scheduler degli eventi MariaDB (consente di eseguire attività pianificate lato server)OFF
ft_max_word_lenLunghezza massima delle parole per la ricerca nel testo completo.Indefinito
ft_min_word_lenLunghezza minima delle parole per la ricerca nel testo completo3
innodb_additional_mem_pool_sizeDimensione del pool di memoria aggiuntivo per InnoDB""
innodb_buffer_pool_sizeDimensione del pool di memoria buffer di InnoDB (archiviazione dei dati e degli indici)""
innodb_flush_log_at_trx_commitFrequenza di scrittura dei log InnoDB su disco""
innodb_large_prefixAbilitazione del prefisso esteso per gli indici InnoDB 
innodb_lock_wait_timeoutTempo massimo di attesa per l'acquisizione dei lock InnoDB""
innodb_log_buffer_sizeDimensione del file di log InnoDB""
innodb_log_file_sizeDimensione dei file di registro InnoDB""
innodb_ft_min_token_sizeDimensione minima del token per la ricerca testuale completaIndefinita
innodb_ft_max_token_sizeDimensione massima del token per la ricerca full-textIndefinito
join_buffer_sizeDimensione del buffer per le operazioni di join nelle query1M
key_buffer_sizeDimensione del buffer della chiave per le tabelle MyISAM4M
lc_time_namesDefinisce la lingua utilizzata per il formato dei nomi dei mesi e dei giorniIndefinito
local_infileAbilita o disabilita la lettura di file in locale0
log_bin_enabledAbilita o disabilita la registrazione binaria delle transazionivero
max_allowed_packetDimensione massima dei pacchetti di rete consentitiIllimitata
max_connect_errorsNumero massimo di errori di connessione prima del blocco10
max_connectionsNumero massimo di connessioni simultaneeIndefinito
max_heap_table_sizeDimensione massima delle tabelle in memoria8M
max_user_connectionsNumero massimo di connessioni simultanee per utente38
myisam_max_sort_file_sizeDimensione massima del file temporaneo utilizzato per l'ordinamento delle tabelle MyISAM2G
myisam_sort_buffer_sizeDimensione del buffer di ordinamento per le tabelle MyISAM16M
myisamrecoverOpzioni di recupero automatico per le tabelle MyISAMmyisam-recover-options
query_cache_enabledAbilita o disabilita la cache delle richieste 
query_cache_limitLimite delle dimensioni dei risultati memorizzati nella cache delle query256K
query_cache_sizeDimensione totale della cache delle richieste64M
query_cache_typeTipo di cache utilizzato per le richieste0
read_buffer_sizeDimensione del buffer di lettura sequenziale2M
read_rnd_buffer_sizeDimensione della cache per le tabelle aperte2M
table_open_cacheNumero di tabelle che il server può mantenere aperte contemporaneamente256
thread_cache_sizeDimensione della cache dei thread1
thread_concurrencyNumero di thread concorrenti (0 = illimitato)0
thread_stackDimensione dello stack per thread256K
timeoutsTempi di attesa (wait_timeout e interactive_timeout)30
tmp_table_sizeDimensione massima delle tabelle temporanee in memoria8M
tmpdirDirectory temporanea utilizzata per i file temporanei"/home/nfs-clients/.mysql_tmp"

 

Ogni parametro non definito mantiene il suo valore predefinito.

 

Modificare i parametri MySQL / MariaDB

Per modificare la configurazione della tua istanza:

  1. Clicca qui per accedere alla gestione del tuo prodotto nel Manager Infomaniak (hai bisogno di aiuto?).
  2. Seleziona il nome del Server Cloud interessato.
  3. Fai clic su MySQL / MariaDB nel menu laterale.
  4. Modificare le impostazioni desiderate e quindi salvare le modifiche.

Questa FAQ è stata utile?

Questa guida spiega come modificare la password di amministrazione di WordPress o di qualsiasi altra applicazione web (Joomla, Drupal, Typo3, PrestaShop, ownCloud, ecc.) installata tramite gli strumenti Infomaniak inclusi nelle offerte di Hosting Web a pagamento.

 

Introduzione

  • Alcune applicazioni consentono anche di modificare la password dell'utente direttamente dalla loro interfaccia dedicata:
    • Esempio: WordPress (gestire utenti, nomi, password, ruoli, ecc.).

 

Modificare la password di un'app web

Per modificare la password di accesso al pannello di amministrazione della tua applicazione web, segui questi passaggi:

  1. Clicca qui per accedere alla gestione degli hosting e dei siti nel tuo Manager Infomaniak (❓: guida).
  2. Fare clic sul nome del sito web interessato.
  3. Fare clic sul menu azioni ⋮ situato a destra dell'applicazione web interessata.
  4. Fare clic su Impostazioni nell'applicazione:
  5. Fare clic su Modifica a destra dell'applicazione:
  6. Nella sezione Password, inserisci la nuova password (per l'accesso con l'ID indicato sopra).
  7. Fai clic sul pulsante Salva in fondo alla pagina:

Questa FAQ è stata utile?

L'utente e il processo "cloud base - ini" vengono utilizzati nell'ambito dell'infrastruttura VPS Cloud / VPS Lite di Infomaniak (ad esempio, nel caso in cui l'istanza venga ricostruita). Ulteriori informazioni


Questa FAQ è stata utile?